MAC

[教學] macOS 安裝多版本PHP,並修改Apache設定文件,任意切版所需的PHP版本

2019/09/11

梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
  先前梅干曾分享過,開啟MAC內建的Apache伺服器,讓MAC變身為網站伺服器,同時再搭配修改設定檔,就可讓Apahce支援PHP,完全不用再安裝其它的軟體,立即就可使用,但PHP則會受限於MAC內建的版本,因此當今天想要用7.0或是目前最新的7.3版本時,要該如何安裝與設定。

  其實方法很簡單,只需要先將PHP的版本下載,並安裝到指定的目錄後,最後再修改Apache的設定文件,再重啟Apache立即就可切換所需的PHP版本,這比安裝MAMP或XAMPP還方便,因此要如何在macOS安裝多版本的PHP與切換,現在就一塊來看看吧!


PHP版本安裝
連結網址: https://php-osx.liip.ch/

Step1
首先,先進到PHP的安裝網站後,選擇所需的PHP版本。
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
Step2
再將上方的語法,拷貝並貼到終端機中,當安裝完畢後,在/usr/local/的目錄下,就會看到剛所安裝的PHP版本資料夾。
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
Step3
當要啟用PHP7.3.8時,將此目錄的路徑拷貝起來。
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
Step4
接著再到/etc/apache2/httpd.conf,將LoadModule php7_module後方,貼上剛所拷貝的路徑。
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
Step5
儲存並重啟apache。
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
Step6
打開瀏覽器,立馬來測試一下,鏘~鏘~變成PHP7.3.8版。
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本
Step7
當要切換其它的版本時,只需重覆步驟3~5,就可任意的切換所需的PHP版本,是不是超方便的呀~
梅問題-[教學] macOS 安裝多版本PHP,並透過Apache任意切版所需的版本